[Jpackage-commits] rpms/devel/hawtdb hawtdb-jpp-depmap.xml, NONE, 1.1 hawtdb-settings.xml, NONE, 1.1 hawtdb.spec, NONE, 1.1

jpackage jpackage at ryu.zarb.org
Sat Oct 1 18:26:45 CEST 2011


Update of /home/projects/jpackage/cvs/rpms/devel/hawtdb
In directory ryu.zarb.org:/tmp/YqGVrIQ2Iw/rpms/devel/hawtdb

Added Files:
	hawtdb-jpp-depmap.xml hawtdb-settings.xml hawtdb.spec 
Log Message:
1.5-1.jpp6

--- NEW FILE: hawtdb-jpp-depmap.xml ---
<dependencies>
<!--
<dependency>
    <maven>
        <groupId>cglib</groupId>
        <artifactId>cglib</artifactId>
        <version>2.1_3</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>cglib21-nodep</artifactId>
        <version>2.1.3</version>
    </jpp>
</dependency>

<dependency>
    <maven>
        <groupId>org.mockito</groupId>
        <artifactId>mockito-all</artifactId>
        <version>1.8.4</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>mockito-all</artifactId>
        <version>1.8.5</version>
    </jpp>
</dependency>

<dependency>
    <maven>
        <groupId>javax.el</groupId>
        <artifactId>el-api</artifactId>
        <version>2.2</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>el_2_2_api</artifactId>
        <version>2.2</version>
    </jpp>
</dependency>

<dependency>
    <maven>
        <groupId>javax.transaction</groupId>
        <artifactId>jta</artifactId>
        <version>1.1</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>jta_1_1_api</artifactId>
        <version>1.1</version>
    </jpp>
</dependency>

<dependency>
    <maven>
        <groupId>javax.xml.bind</groupId>
        <artifactId>jsr173_api</artifactId>
        <version>1.0</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>stax_1_0_api</artifactId>
        <version>1.0</version>
    </jpp>
</dependency>


   <dependency>
      <maven>
         <groupId>junit</groupId>
         <artifactId>junit</artifactId>
         <version>4.5</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>junit4</artifactId>
         <version>4.8</version>
      </jpp>
   </dependency>


<dependency>
    <maven>
        <groupId>org.apache.commons</groupId>
        <artifactId>commons-io</artifactId>
        <version>1.3.2</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>commons-io</artifactId>
        <version>1.3.2</version>
    </jpp>
</dependency>

<dependency>
    <maven>
        <groupId>ldapsdk</groupId>
        <artifactId>ldapsdk</artifactId>
        <version>4.1</version>
    </maven>
    <jpp>
        <groupId>JPP</groupId>
        <artifactId>ldapsdk</artifactId>
        <version>4.18</version>
    </jpp>
</dependency>

   <dependency>
      <maven>
         <groupId>groovy</groupId>
         <artifactId>gram</artifactId>
         <version>1.1</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>groovy-module-gram</artifactId>
         <version>1.2</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>bouncycastle</groupId>
         <artifactId>bcprov-jdk15</artifactId>
         <version>140</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>bcprov</artifactId>
         <version>1.43</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>org.springframework.ws</groupId>
         <artifactId>spring-oxm-tiger</artifactId>
         <version>1.5.8</version>
      </maven>
      <jpp>
         <groupId>JPP/maven2</groupId>
         <artifactId>empty-dep</artifactId>
         <version>2.0.8</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>xmlbeans</groupId>
         <artifactId>xmlpublic</artifactId>
         <version>2.0.0-beta1</version>
      </maven>
      <jpp>
         <groupId>JPP/xmlbeans</groupId>
         <artifactId>xmlpublic</artifactId>
         <version>2.4.0</version>
      </jpp>
   </dependency>
   <dependency>
      <maven>
         <groupId>xmlbeans</groupId>
         <artifactId>xbean_xpath</artifactId>
         <version>2.0.0-beta1</version>
      </maven>
      <jpp>
         <groupId>JPP/xmlbeans</groupId>
         <artifactId>xbean_xpath</artifactId>
         <version>2.4.0</version>
      </jpp>
   </dependency>
   <dependency>
      <maven>
         <groupId>xmlbeans</groupId>
         <artifactId>xbean</artifactId>
         <version>2.0.0-beta1</version>
      </maven>
      <jpp>
         <groupId>JPP/xmlbeans</groupId>
         <artifactId>xbean</artifactId>
         <version>2.4.0</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>axis</groupId>
         <artifactId>axis</artifactId>
         <version>1.2-RC1</version>
      </maven>
      <jpp>
         <groupId>JPP/axis</groupId>
         <artifactId>axis</artifactId>
         <version>1.4</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>net.sf.josql</groupId>
         <artifactId>josql</artifactId>
         <version>1.5</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>josql</artifactId>
         <version>2.2</version>
      </jpp>
   </dependency>
   <dependency>
      <maven>
         <groupId>net.sf.josql</groupId>
         <artifactId>gentlyweb-utils</artifactId>
         <version>1.5</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>gentlyweb-utils</artifactId>
         <version>1.1</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>junit</groupId>
         <artifactId>junit-dep</artifactId>
         <version>4.4</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>junit44</artifactId>
         <version>4.4</version>
      </jpp>
   </dependency>

   <dependency>
      <maven>
         <groupId>org.apache.geronimo.specs</groupId>
         <artifactId>geronimo-jacc_1.1_spec</artifactId>
         <version>1.0.1</version>
      </maven>
      <jpp>
         <groupId>JPP</groupId>
         <artifactId>geronimo-jacc-1.1-api</artifactId>
         <version>1.0.1</version>
      </jpp>
   </dependency>
-->

</dependencies>

--- NEW FILE: hawtdb.spec ---
# Copyright (c) 2000-2011, JPackage Project
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
#
# 1. Redistributions of source code must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
# 2. Redistributions in binary form must reproduce the above copyright
#    notice, this list of conditions and the following disclaimer in the
#    documentation and/or other materials provided with the
#    distribution.
# 3. Neither the name of the JPackage Project nor the names of its
#    contributors may be used to endorse or promote products derived
#    from this software without specific prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#

%define with()          %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
%define without()       %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}}
%define bcond_with()    %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
%define bcond_without() %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}

%bcond_with gcj_support

%if %with gcj_support
%define gcj_support 1
%else
%define gcj_support 0
%endif

%define section         free

Name:           hawtdb
Version:        1.5
Release:        1%{?dist}
Epoch:          0
Summary:        HawtDB embedded DB
License:        Apache Software License 2.0
Group:          Development/Libraries/Java
Url:            http://hawtdb.fusesource.org/
Source0:        https://download.github.com/chirino-hawtdb-hawtdb-1.5-0-ge942bd2.zip

Source1:        %{name}-settings.xml
Source2:        %{name}-jpp-depmap.xml
Source3:        http://repo.fusesource.com/nexus/content/groups/public/org/fusesource/mvnplugins/fuse-jxr-skin/1.9/fuse-jxr-skin-1.9.jar

BuildRequires:  jpackage-utils >= 0:1.7.5
BuildRequires:  java-devel >= 0:1.6.0
BuildRequires:  ant >= 0:1.7
BuildRequires:  apache-commons-parent >= 0:12
BuildRequires:  maven2 >= 0:2.0.8
BuildRequires:  maven2-plugin-antrun
BuildRequires:  maven2-plugin-assembly
BuildRequires:  maven2-plugin-compiler
BuildRequires:  maven2-plugin-install
BuildRequires:  maven2-plugin-jar
BuildRequires:  maven2-plugin-javadoc
BuildRequires:  maven2-plugin-resources
BuildRequires:  maven-surefire-maven-plugin
BuildRequires:  maven-surefire-provider-junit4
BuildRequires:  hawtbuf
Requires(post):    jpackage-utils >= 0:1.7.5
Requires(postun):  jpackage-utils >= 0:1.7.5
Requires:  java >= 0:1.6.0
Requires:  hawtbuf
%if ! %{gcj_support}
BuildArch:      noarch
%endif
BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

%if %{gcj_support}
BuildRequires:          java-gcj-compat-devel
Requires(post):         java-gcj-compat
Requires(postun):       java-gcj-compat
%endif

%description
HawtDB is a high-performance key/value embedded database for
Java applications.

%package javadoc
Summary:        Javadoc for %{name}
Group:          Development/Documentation

%description javadoc
%{summary}.

%prep
%setup -q  -n chirino-hawtdb-7530626

cp -p %{SOURCE1} settings.xml
sed -i -e "s|<url>__JPP_URL_PLACEHOLDER__</url>|<url>file://`pwd`/.m2/repository</url>|g" settings.xml
sed -i -e "s|<url>__JAVADIR_PLACEHOLDER__</url>|<url>file://`pwd`/external_repo</url>|g" settings.xml
sed -i -e "s|<url>__MAVENREPO_DIR_PLACEHOLDER__</url>|<url>file://`pwd`/.m2/repository</url>|g" settings.xml
sed -i -e "s|<url>__MAVENDIR_PLUGIN_PLACEHOLDER__</url>|<url>file:///usr/share/maven2/plugins</url>|g" settings.xml
sed -i -e "s|<url>__ECLIPSEDIR_PLUGIN_PLACEHOLDER__</url>|<url>file:///usr/share/eclipse/plugins</url>|g" settings.xml

mkdir external_repo
ln -s %{_javadir} external_repo/JPP

%build
export MAVEN_REPO_LOCAL=$(pwd)/.m2/repository
mkdir -p ${MAVEN_REPO_LOCAL}
mkdir -p ${MAVEN_REPO_LOCAL}/org/fusesource/mvnplugins/fuse-jxr-skin/1.9/
cp %{SOURCE3} ${MAVEN_REPO_LOCAL}/org/fusesource/mvnplugins/fuse-jxr-skin/1.9/fuse-jxr-skin-1.9.jar

export MAVEN_SETTINGS=$(pwd)/settings.xml

%{_bindir}/mvn-jpp \
        -e \
        -s ${MAVEN_SETTINGS} \
        -Dmaven2.jpp.depmap.file=%{SOURCE2} \
        -Dmaven.repo.local=${MAVEN_REPO_LOCAL} \
        install javadoc:javadoc

%install
rm -rf $RPM_BUILD_ROOT
# jars
install -d -m 755 $RPM_BUILD_ROOT%{_javadir}/

install -m 644 target/%{name}-%{version}.jar \
               $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar

(cd $RPM_BUILD_ROOT%{_javadir}/ && for jar in *-%{version}*; do ln -sf ${jar} `echo $jar| sed  "s|-%{version}||g"`; done)
# Install pom files
install -dm 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
install -m 644 pom.xml $RPM_BUILD_ROOT%{_datadir}/maven2/poms/JPP-%{name}.pom
%add_to_maven_depmap org.fusesource.hawtdb hawtdb %{version} JPP %{name} 

# javadoc
install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
cp -pr target/site/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}

%if %{gcj_support}
%{_bindir}/aot-compile-rpm
%endif

%clean
rm -rf $RPM_BUILD_ROOT

%post
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
  %{_bindir}/rebuild-gcj-db
fi
%endif

%postun
%update_maven_depmap
%if %{gcj_support}
if [ -x %{_bindir}/rebuild-gcj-db ]
then
  %{_bindir}/rebuild-gcj-db
fi
%endif

%files
%defattr(-,root,root)
%{_datadir}/maven2/poms/*
%{_mavendepmapfragdir}/*
%{_javadir}/*.jar
%if %{gcj_support}
%attr(-,root,root) %{_libdir}/gcj/%{name}/%{name}-%{version}.jar.*
%endif

%files javadoc
%defattr(-,root,root)
%doc %{_javadocdir}/*

%changelog
* Sat Oct 01 2011 Ralph Apel <r.apel at r-apel.de> - 0:1.5-1
- first release


--- NEW FILE: hawtdb-settings.xml ---
<settings>
	<profiles>
		<profile>
			<id>JPP</id>
			<repositories>
				<repository>
					<id>internal</id>
					<layout>jpp</layout>
					<url>__JPP_URL_PLACEHOLDER__</url>
				</repository>
				<repository>
					<id>external</id>
					<layout>jpp</layout>
					<url>__JAVADIR_PLACEHOLDER__</url>
				</repository>
				<repository>
					<id>local</id>
					<layout>jpp</layout>
					<url>__MAVENREPO_DIR_PLACEHOLDER__</url>
				</repository>
			</repositories>
			<pluginRepositories>
				<pluginRepository>
					<id>plugins-internal</id>
					<name>plugins-internal</name>
					<layout>jpp</layout>
					<url>__JPP_URL_PLACEHOLDER__</url>
				</pluginRepository>
				<pluginRepository>
					<id>plugins-external</id>
					<name>plugins-external</name>
					<layout>jpp</layout>
					<url>__JAVADIR_PLACEHOLDER__</url>
				</pluginRepository>
				<pluginRepository>
					<id>plugins-maven</id>
					<name>plugins-maven</name>
					<layout>jpp</layout>
					<url>__MAVENDIR_PLUGIN_PLACEHOLDER__</url>
				</pluginRepository>
			</pluginRepositories>
		</profile>
	</profiles>
	<activeProfiles>
		<activeProfile>JPP</activeProfile>
	</activeProfiles>
</settings>




More information about the JPackage-commits mailing list