[Jpackage-commits] dist/swing-layout/JPP-6 swing-layout.spec, 1.1, 1.2

David Walluck david at ryu.zarb.org
Wed Feb 24 21:31:22 CET 2010


Update of /home/projects/jpackage/cvs/dist/swing-layout/JPP-6
In directory ryu.zarb.org:/tmp/cvs-serv8850

Modified Files:
	swing-layout.spec 
Log Message:
- remove jpackage-utils version requirement
- fix BuildRoot on non-Fedora systems
- fix GCJ Requires


Index: swing-layout.spec
===================================================================
RCS file: /home/projects/jpackage/cvs/dist/swing-layout/JPP-6/swing-layout.spec,v
retrieving revision 1.1
retrieving revision 1.2
diff -C 2 -d -r1.1 -r1.2
*** swing-layout.spec	22 Feb 2010 16:05:14 -0000	1.1
--- swing-layout.spec	24 Feb 2010 20:31:19 -0000	1.2
***************
*** 34,38 ****
  Name:           swing-layout
  Version:        1.0.3
! Release:        5%{?dist}
  Summary:        Natural layout for Swing panels
  
--- 34,38 ----
  Name:           swing-layout
  Version:        1.0.3
! Release:        6%{?dist}
  Summary:        Natural layout for Swing panels
  
***************
*** 43,49 ****
  Source0:        %{name}-%{version}-src.zip
  Source1:        %{name}-%{version}.pom
! BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  
! BuildRequires:  jpackage-utils >= 0:5.0.0
  BuildRequires:  java-devel >= 1.6
  BuildRequires:  ant
--- 43,49 ----
  Source0:        %{name}-%{version}-src.zip
  Source1:        %{name}-%{version}.pom
! BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
  
! BuildRequires:  jpackage-utils
  BuildRequires:  java-devel >= 1.6
  BuildRequires:  ant
***************
*** 52,63 ****
  
  %if %{with_gcj}
! BuildRequires:    java-gcj-compat-devel >= 1.0.31
! Requires(post):   java-gcj-compat >= 1.0.31
! Requires(postun): java-gcj-compat >= 1.0.31
  %else
  BuildArch:      noarch
  %endif
! Requires(post):    jpackage-utils >= 0:5.0.0
! Requires(postun):  jpackage-utils >= 0:5.0.0
  
  
--- 52,61 ----
  
  %if %{with_gcj}
! BuildRequires:    java-gcj-compat-devel
  %else
  BuildArch:      noarch
  %endif
! Requires(post):    jpackage-utils
! Requires(postun):  jpackage-utils
  
  
***************
*** 141,144 ****
--- 139,147 ----
  
  %changelog
+ * Wed Feb 24 2010 David Walluck <dwalluck at redhat.com> 0:1.0.3-6
+ - remove jpackage-utils version requirement
+ - fix BuildRoot on non-Fedora systems
+ - fix GCJ Requires
+ 
  * Mon Feb 22 2010 Ralph Apel <r.apel at r-apel.de> - 1.0.3-5
  - Adapt to JPP6




More information about the JPackage-commits mailing list