[Jpackage-commits] dist/plexus-containers/devel plexus-containers.spec, 1.24, 1.25

jpackage jpackage at ryu.zarb.org
Tue Dec 14 20:43:36 CET 2010


Update of /home/projects/jpackage/cvs/dist/plexus-containers/devel
In directory ryu.zarb.org:/tmp/cvs-serv13963

Modified Files:
	plexus-containers.spec 
Log Message:
BR depmap plexus-component-metadata

Index: plexus-containers.spec
===================================================================
RCS file: /home/projects/jpackage/cvs/dist/plexus-containers/devel/plexus-containers.spec,v
retrieving revision 1.24
retrieving revision 1.25
diff -C 2 -d -r1.24 -r1.25
*** plexus-containers.spec	14 Dec 2010 19:39:44 -0000	1.24
--- plexus-containers.spec	14 Dec 2010 19:43:34 -0000	1.25
***************
*** 70,81 ****
  BuildRequires:  maven2-plugin-compiler
  BuildRequires:  maven2-plugin-install
  BuildRequires:  maven2-plugin-jar
  BuildRequires:  maven2-plugin-javadoc
  BuildRequires:  maven2-plugin-resources
  BuildRequires:  maven-surefire-maven-plugin
  BuildRequires:  maven-surefire-provider-junit
  BuildRequires:  maven-doxia
  BuildRequires:  maven-doxia-sitetools
! BuildRequires:  maven2-common-poms >= 1.0
  BuildRequires:  maven-release
  BuildRequires:  apache-commons-parent
--- 70,83 ----
  BuildRequires:  maven2-plugin-compiler
  BuildRequires:  maven2-plugin-install
+ BuildRequires:  maven2-plugin-invoker
  BuildRequires:  maven2-plugin-jar
  BuildRequires:  maven2-plugin-javadoc
  BuildRequires:  maven2-plugin-resources
+ BuildRequires:  maven2-common-poms >= 1.0
  BuildRequires:  maven-surefire-maven-plugin
  BuildRequires:  maven-surefire-provider-junit
  BuildRequires:  maven-doxia
  BuildRequires:  maven-doxia-sitetools
! BuildRequires:  maven-plugin-tools
  BuildRequires:  maven-release
  BuildRequires:  apache-commons-parent
***************
*** 85,91 ****
--- 87,96 ----
  BuildRequires:  junit
  %endif
+ BuildRequires:  google-collections08
  BuildRequires:  plexus-classworlds >= 0:2.2.2
+ BuildRequires:  plexus-cli
  BuildRequires:  plexus-utils
  BuildRequires:  qdox >= 0:1.9.2
+ BuildRequires:  xbean >= 0:3.4
  %if %{gcj_support}
  BuildRequires:  java-gcj-compat-devel
***************
*** 95,101 ****
--- 100,109 ----
  
  Requires:  java >= 0:1.6.0
+ Requires:  google-collections08
  Requires:  plexus-classworlds >= 0:2.2.2
+ Requires:  plexus-cli
  Requires:  plexus-utils
  Requires:  qdox >= 0:1.9.2
+ Requires:  xbean >= 0:3.4
  
  Requires(post):    jpackage-utils >= 0:1.7.5
***************
*** 183,188 ****
          -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
          -Dmaven2.jpp.depmap.file=%{SOURCE4} \
          -Daggregate=true \
!         install javadoc:javadoc
  
  %else
--- 191,203 ----
          -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
          -Dmaven2.jpp.depmap.file=%{SOURCE4} \
+         -Dmaven.test.failure.ignore=true \
+         install 
+ 
+     mvn-jpp \
+         -e -s $(pwd)/settings.xml \
+         -Dmaven.repo.local=$MAVEN_REPO_LOCAL \
+         -Dmaven2.jpp.depmap.file=%{SOURCE4} \
          -Daggregate=true \
!         javadoc:aggregate
  
  %else
***************
*** 232,235 ****
--- 247,251 ----
  %add_to_maven_depmap org.codehaus.plexus containers-component-metadata  %{namedversion} JPP/%{parent} containers-component-metadata
  %add_to_maven_depmap org.codehaus.plexus plexus-component-metadata  %{namedversion} JPP/%{parent} containers-component-metadata
+ %add_to_maven_depmap org.codehaus.plexus containers-component-javadoc  %{namedversion} JPP/%{parent} containers-component-javadoc
  %add_to_maven_depmap org.codehaus.plexus plexus-component-javadoc  %{namedversion} JPP/%{parent} containers-component-javadoc
  %add_to_maven_depmap org.codehaus.plexus plexus-javadoc  %{namedversion} JPP/%{parent} containers-component-javadoc




More information about the JPackage-commits mailing list