[Jpackage-commits] rpms/free/xml-commons xml-commons.spec, 1.10, 1.10.2.1 xml-commons.which10.script, 1.5, 1.5.2.1 xml-commons.which11.script, 1.5, 1.5.2.1

jpackage jpackage at ryu.zarb.org
Fri Feb 20 23:41:25 CET 2009


Update of /home/projects/jpackage/cvs/rpms/free/xml-commons
In directory ryu.zarb.org:/tmp/CM9JqkN61X/rpms/free/xml-commons

Modified Files:
      Tag: JPACKAGE-5_0
	xml-commons.spec xml-commons.which10.script 
	xml-commons.which11.script 
Log Message:
1.3.04-5.jpp5



Index: xml-commons.spec
===================================================================
RCS file: /home/projects/jpackage/cvs/rpms/free/xml-commons/xml-commons.spec,v
retrieving revision 1.10
retrieving revision 1.10.2.1
diff -C 2 -d -r1.10 -r1.10.2.1
*** xml-commons.spec	11 Aug 2008 01:23:32 -0000	1.10
--- xml-commons.spec	20 Feb 2009 22:41:22 -0000	1.10.2.1
***************
*** 57,61 ****
  Name:           xml-commons
  Version:        1.3.04
! Release:        4%{?dist}
  Summary:        Common code for XML projects
  Epoch:          0
--- 57,61 ----
  Name:           xml-commons
  Version:        1.3.04
! Release:        5%{?dist}
  Summary:        Common code for XML projects
  Epoch:          0
***************
*** 126,130 ****
  Provides:       sax = 2.0
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{apis_version_1_1}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
--- 126,130 ----
  Provides:       sax = 2.0
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{apis_version_1_1}-%{release}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
***************
*** 142,146 ****
  Group:          Text Processing/Markup/XML
  Summary:        Javadoc for %{name}-jaxp-1.1-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{apis_version_1_1}
  
  %description jaxp-1.1-apis-javadoc
--- 142,146 ----
  Group:          Text Processing/Markup/XML
  Summary:        Javadoc for %{name}-jaxp-1.1-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{apis_version_1_1}-%{release}
  
  %description jaxp-1.1-apis-javadoc
***************
*** 160,164 ****
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.1-apis
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires:       ant >= 0:1.6
--- 160,164 ----
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.1-apis = %{epoch}:%{version}-%{release}
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires:       ant >= 0:1.6
***************
*** 182,186 ****
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.1-apis
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires(preun): %{_sbindir}/update-alternatives
--- 182,186 ----
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.1-apis = %{epoch}:%{version}-%{release}
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires(preun): %{_sbindir}/update-alternatives
***************
*** 203,207 ****
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.2-apis
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires(preun): %{_sbindir}/update-alternatives
--- 203,207 ----
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.2-apis = %{epoch}:%{version}-%{release}
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires(preun): %{_sbindir}/update-alternatives
***************
*** 225,229 ****
  Provides:       sax = 2.0.1
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{apis_version_1_2}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
--- 225,229 ----
  Provides:       sax = 2.0.1
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{apis_version_1_2}-%{release}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
***************
*** 241,245 ****
  Group:          Development/Documentation
  Summary:        Javadoc for %{name}-jaxp-1.2-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{apis_version_1_2}
  
  %description jaxp-1.2-apis-javadoc
--- 241,245 ----
  Group:          Development/Documentation
  Summary:        Javadoc for %{name}-jaxp-1.2-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{apis_version_1_2}-%{release}
  
  %description jaxp-1.2-apis-javadoc
***************
*** 260,264 ****
  Provides:       sax = 2.0.2
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{version}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
--- 260,264 ----
  Provides:       sax = 2.0.2
  Provides:       xslt = 1.0
! Provides:       xml-commons-apis = %{epoch}:%{version}-%{release}
  Obsoletes:      xml-commons-apis <= 0:1.3.02-2jpp
  Requires:       jpackage-utils >= 0:1.6
***************
*** 277,281 ****
  Group:          Development/Documentation
  Summary:        Javadoc for %{name}-jaxp-1.3-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{version}
  
  %description jaxp-1.3-apis-javadoc
--- 277,281 ----
  Group:          Development/Documentation
  Summary:        Javadoc for %{name}-jaxp-1.3-apis
! Provides:       %{name}-apis-javadoc = %{epoch}:%{version}-%{release}
  
  %description jaxp-1.3-apis-javadoc
***************
*** 295,299 ****
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.3-apis
  Requires:       ant >= 0:1.6
  Requires:       %{name} = %{epoch}:%{version}-%{release}
--- 295,299 ----
  Requires:       jpackage-utils >= 0:1.6
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.3-apis = %{epoch}:%{version}-%{release}
  Requires:       ant >= 0:1.6
  Requires:       %{name} = %{epoch}:%{version}-%{release}
***************
*** 318,322 ****
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.3-apis
  Requires(preun): %{_sbindir}/update-alternatives
  Requires(post): %{_sbindir}/update-alternatives
--- 318,322 ----
  Requires:       %{name} = %{epoch}:%{version}-%{release}
  Requires:       jaxp_parser_impl
! Requires:       xml-commons-jaxp-1.3-apis = %{epoch}:%{version}-%{release}
  Requires(preun): %{_sbindir}/update-alternatives
  Requires(post): %{_sbindir}/update-alternatives
***************
*** 1067,1070 ****
--- 1067,1074 ----
  
  %changelog
+ * Fri Feb 20 2009 David Walluck <dwalluck at redhat.com> 0:1.3.04-5
+ - fix some Requires that should have been versioned
+ - update some Provides to also include the release tag
+ 
  * Sun Aug 10 2008 David Walluck <dwalluck at redhat.com> 0:1.3.04-2
  - fix broken symlink xml-commons-resolver-12-1.3.03 (bug #284)




More information about the JPackage-commits mailing list